aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/qml/qmltc/QmltcTests/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/qml/qmltc/QmltcTests/CMakeLists.txt')
-rw-r--r--tests/auto/qml/qmltc/QmltcTests/CMakeLists.txt21
1 files changed, 20 insertions, 1 deletions
diff --git a/tests/auto/qml/qmltc/QmltcTests/CMakeLists.txt b/tests/auto/qml/qmltc/QmltcTests/CMakeLists.txt
index 870d21f61d..4c472ec4ab 100644
--- a/tests/auto/qml/qmltc/QmltcTests/CMakeLists.txt
+++ b/tests/auto/qml/qmltc/QmltcTests/CMakeLists.txt
@@ -22,6 +22,8 @@ set(cpp_sources
cpptypes/singletontype.h cpptypes/singletontype.cpp
cpptypes/typewithnamespace.h cpptypes/typewithnamespace.cpp
cpptypes/typewithsignal.h
+ cpptypes/custominitialization.h
+ cpptypes/typewithrequiredproperties.h
)
set(qml_sources
@@ -44,11 +46,16 @@ set(qml_sources
regexpBindings.qml
AliasBase.qml
aliasAssignments.qml
+ Connections.qml
qtbug103956/SubComponent.qml
qtbug103956/MainComponent.qml
qtbug103956/qtbug103956_main.qml
+ qtbug120700_main.qml
+
+ qtbug123476.qml
+
signalHandlers.qml
javaScriptFunctions.qml
changingBindings.qml
@@ -108,6 +115,9 @@ set(qml_sources
inlineComponentsFromDifferentFiles.qml
singletons.qml
mySignals.qml
+ stringToUrl.qml
+ myCheckBox.qml
+ signalConnections.qml
# support types:
DefaultPropertySingleChild.qml
@@ -125,6 +135,8 @@ set(qml_sources
NamespacedTypes.qml
badFile.qml
+
+ requiredProperties.qml
)
set(js_sources
@@ -135,10 +147,16 @@ set(common_libraries
Qt::Core
Qt::QmlPrivate
Qt::QuickPrivate
+ Qt::QuickTemplates2Private
Qt::TestPrivate
Qt::Gui # QColor, QMatrix4x4, ...
)
+if (QT_FEATURE_qml_table_model)
+ list(APPEND qml_sources QmlTableModel.qml)
+ list(APPEND common_libraries Qt::LabsQmlModelsPrivate)
+endif()
+
set_source_files_properties(NameConflict.qml PROPERTIES
QT_QMLTC_FILE_BASENAME ResolvedNameConflict)
@@ -166,10 +184,11 @@ qt_internal_add_resource(qmltc_test_module "qmake_immediate"
${qmake_immediate_resource_files}
)
+qt_policy(SET QTP0001 NEW)
+
qt6_add_qml_module(qmltc_test_module
VERSION 1.0
URI QmltcTests
- AUTO_RESOURCE_PREFIX
SOURCES
${cpp_sources}
QML_FILES