aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/qml/qmltc_qprocess/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/qml/qmltc_qprocess/CMakeLists.txt')
-rw-r--r--tests/auto/qml/qmltc_qprocess/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/tests/auto/qml/qmltc_qprocess/CMakeLists.txt b/tests/auto/qml/qmltc_qprocess/CMakeLists.txt
index e6a031ddcf..46f1d856d3 100644
--- a/tests/auto/qml/qmltc_qprocess/CMakeLists.txt
+++ b/tests/auto/qml/qmltc_qprocess/CMakeLists.txt
@@ -15,6 +15,15 @@ qt6_add_qml_module(tst_qmltc_qprocess
)
add_dependencies(tst_qmltc_qprocess Qt::qmltc)
+# fetch --resource arguments manually (mimics the logic of qmltc compilation
+# command)
+_qt_internal_genex_getjoinedproperty(qrc_args tst_qmltc_qprocess
+ _qt_generated_qrc_files "" "_::_"
+)
+target_compile_definitions(tst_qmltc_qprocess PRIVATE
+ TST_QMLTC_QPROCESS_RESOURCES="${qrc_args}"
+)
+
qt_internal_extend_target(tst_qmltc_qprocess CONDITION ANDROID OR IOS
DEFINES
QT_QMLTEST_DATADIR=\\\":/data\\\"