aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/qml/qqmlcomponent/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/qml/qqmlcomponent/CMakeLists.txt')
-rw-r--r--tests/auto/qml/qqmlcomponent/CMakeLists.txt11
1 files changed, 10 insertions, 1 deletions
diff --git a/tests/auto/qml/qqmlcomponent/CMakeLists.txt b/tests/auto/qml/qqmlcomponent/CMakeLists.txt
index cab87ac08d..874c7f0cc3 100644
--- a/tests/auto/qml/qqmlcomponent/CMakeLists.txt
+++ b/tests/auto/qml/qqmlcomponent/CMakeLists.txt
@@ -7,6 +7,12 @@
## tst_qqmlcomponent Test:
#####################################################################
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_qqmlcomponent LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
+
# Collect test data
file(GLOB_RECURSE test_data_glob
RELATIVE ${CMAKE_CURRENT_SOURCE_DIR}
@@ -36,10 +42,13 @@ if(TARGET Qt::QuickControls2)
target_compile_definitions(tst_qqmlcomponent PRIVATE HAS_CONTROLS)
endif()
+qt_policy(SET QTP0001 NEW)
+
qt_add_qml_module(
tst_qqmlcomponent
+ SOURCES
+ lifecyclewatcher.h
URI test
- AUTO_RESOURCE_PREFIX
QML_FILES
"data/TestComponentWithIC.qml"
"data/withAot.qml"