aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/qml/qqmlimport/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/qml/qqmlimport/CMakeLists.txt')
-rw-r--r--tests/auto/qml/qqmlimport/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/tests/auto/qml/qqmlimport/CMakeLists.txt b/tests/auto/qml/qqmlimport/CMakeLists.txt
index 32aeec0966..803234787b 100644
--- a/tests/auto/qml/qqmlimport/CMakeLists.txt
+++ b/tests/auto/qml/qqmlimport/CMakeLists.txt
@@ -7,6 +7,12 @@
## tst_qqmlimport Test:
#####################################################################
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_qqmlimport LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
+
# Collect test data
file(GLOB_RECURSE test_data_glob
RELATIVE ${CMAKE_CURRENT_SOURCE_DIR}
@@ -44,6 +50,14 @@ qt_internal_add_resource(tst_qqmlimport "preferred"
"Preferred.qml"
)
+qt_internal_add_resource(tst_qqmlimport "preferred2"
+ PREFIX
+ "/qqmlimport/ModuleWithPrefer2/"
+ FILES
+ "Preferred.qml"
+ "qmldir"
+)
+
## Scopes:
#####################################################################