aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/qmldom/errormessage/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/qmldom/errormessage/CMakeLists.txt')
-rw-r--r--tests/auto/qmldom/errormessage/CMakeLists.txt14
1 files changed, 11 insertions, 3 deletions
diff --git a/tests/auto/qmldom/errormessage/CMakeLists.txt b/tests/auto/qmldom/errormessage/CMakeLists.txt
index 4a8f5043b9..7c82876827 100644
--- a/tests/auto/qmldom/errormessage/CMakeLists.txt
+++ b/tests/auto/qmldom/errormessage/CMakeLists.txt
@@ -1,15 +1,23 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
# Generated from errormessage.pro.
#####################################################################
## tst_qmldomerrormessage Test:
#####################################################################
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_qmldomerrormessage LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
+
qt_internal_add_test(tst_qmldomerrormessage
SOURCES
- tst_qmldomerrormessage.cpp
+ tst_qmldomerrormessage.cpp tst_qmldomerrormessage.h
DEFINES
QT_DEPRECATED_WARNINGS
- PUBLIC_LIBRARIES
- Qt::QmlDevToolsPrivate
+ LIBRARIES
Qt::QmlDomPrivate
)