aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/qmldom/path/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/qmldom/path/CMakeLists.txt')
-rw-r--r--tests/auto/qmldom/path/CMakeLists.txt14
1 files changed, 11 insertions, 3 deletions
diff --git a/tests/auto/qmldom/path/CMakeLists.txt b/tests/auto/qmldom/path/CMakeLists.txt
index 4c4109dd02..bf3e5d20f5 100644
--- a/tests/auto/qmldom/path/CMakeLists.txt
+++ b/tests/auto/qmldom/path/CMakeLists.txt
@@ -1,15 +1,23 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
# Generated from path.pro.
#####################################################################
## tst_qmldompath Test:
#####################################################################
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_qmldompath LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
+
qt_internal_add_test(tst_qmldompath
SOURCES
- tst_qmldompath.cpp
+ tst_qmldompath.cpp tst_qmldompath.h
DEFINES
QT_DEPRECATED_WARNINGS
- PUBLIC_LIBRARIES
- Qt::QmlDevToolsPrivate
+ LIBRARIES
Qt::QmlDomPrivate
)