aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/qmldom/stringdumper/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/qmldom/stringdumper/CMakeLists.txt')
-rw-r--r--tests/auto/qmldom/stringdumper/CMakeLists.txt14
1 files changed, 11 insertions, 3 deletions
diff --git a/tests/auto/qmldom/stringdumper/CMakeLists.txt b/tests/auto/qmldom/stringdumper/CMakeLists.txt
index 1c809c2827..2b09281302 100644
--- a/tests/auto/qmldom/stringdumper/CMakeLists.txt
+++ b/tests/auto/qmldom/stringdumper/CMakeLists.txt
@@ -1,17 +1,25 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
# Generated from stringdumper.pro.
#####################################################################
## tst_qmldomstringdumper Test:
#####################################################################
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_qmldomstringdumper LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
+
qt_internal_add_test(tst_qmldomstringdumper
SOURCES
- tst_qmldomstringdumper.cpp
+ tst_qmldomstringdumper.cpp tst_qmldomstringdumper.h
DEFINES
QT_DEPRECATED_WARNINGS
INCLUDE_DIRECTORIES
../../../../src/qmldom
- PUBLIC_LIBRARIES
- Qt::QmlDevToolsPrivate
+ LIBRARIES
Qt::QmlDomPrivate
)