aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/qmlls/qmlls/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/qmlls/qmlls/CMakeLists.txt')
-rw-r--r--tests/auto/qmlls/qmlls/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/tests/auto/qmlls/qmlls/CMakeLists.txt b/tests/auto/qmlls/qmlls/CMakeLists.txt
index e5f4bf822c..b3580c74e7 100644
--- a/tests/auto/qmlls/qmlls/CMakeLists.txt
+++ b/tests/auto/qmlls/qmlls/CMakeLists.txt
@@ -1,6 +1,12 @@
# Copyright (C) 2022 The Qt Company Ltd.
# SPDX-License-Identifier: BSD-3-Clause
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_qmlls LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
+
file(GLOB_RECURSE test_data_glob
RELATIVE ${CMAKE_CURRENT_SOURCE_DIR}
data)
@@ -25,3 +31,9 @@ qt_internal_extend_target(tst_qmlls CONDITION ANDROID OR IOS
DEFINES
QT_QMLTEST_DATADIR=":/domdata"
)
+
+if (TARGET qmlls)
+ # in a standalone build, the qmlls target won't exist
+ # but we assume that it is available if you manually set up the test
+ add_dependencies(tst_qmlls qmlls)
+endif()