aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/qmltest/itemgrabber/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/qmltest/itemgrabber/CMakeLists.txt')
-rw-r--r--tests/auto/qmltest/itemgrabber/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/tests/auto/qmltest/itemgrabber/CMakeLists.txt b/tests/auto/qmltest/itemgrabber/CMakeLists.txt
index 378cba80d6..34b0483cd8 100644
--- a/tests/auto/qmltest/itemgrabber/CMakeLists.txt
+++ b/tests/auto/qmltest/itemgrabber/CMakeLists.txt
@@ -7,6 +7,12 @@
## itemgrabber Test:
#####################################################################
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(itemgrabber LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
+
qt_internal_add_test(itemgrabber
GUI
QMLTEST