aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/quick/examples/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/quick/examples/CMakeLists.txt')
-rw-r--r--tests/auto/quick/examples/CMakeLists.txt15
1 files changed, 12 insertions, 3 deletions
diff --git a/tests/auto/quick/examples/CMakeLists.txt b/tests/auto/quick/examples/CMakeLists.txt
index 5bcaa3f93a..74fe0fba51 100644
--- a/tests/auto/quick/examples/CMakeLists.txt
+++ b/tests/auto/quick/examples/CMakeLists.txt
@@ -1,15 +1,24 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: LicenseRef-Qt-Commercial OR BSD-3-Clause
+
# Generated from examples.pro.
#####################################################################
## tst_examples Test:
#####################################################################
-qt_internal_add_test(tst_examples
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_quick_examples LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
+
+qt_internal_add_test(tst_quick_examples
SOURCES
tst_examples.cpp
DEFINES
- SRCDIR=\\\"${CMAKE_CURRENT_SOURCE_DIR}\\\"
- PUBLIC_LIBRARIES
+ SRCDIR="${CMAKE_CURRENT_SOURCE_DIR}"
+ LIBRARIES
Qt::CorePrivate
Qt::Gui
Qt::GuiPrivate