aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/quick/qquickpixmapcache/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/quick/qquickpixmapcache/CMakeLists.txt')
-rw-r--r--tests/auto/quick/qquickpixmapcache/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/tests/auto/quick/qquickpixmapcache/CMakeLists.txt b/tests/auto/quick/qquickpixmapcache/CMakeLists.txt
index 1e1d35a8af..97735172f2 100644
--- a/tests/auto/quick/qquickpixmapcache/CMakeLists.txt
+++ b/tests/auto/quick/qquickpixmapcache/CMakeLists.txt
@@ -24,7 +24,6 @@ qt_internal_add_test(tst_qquickpixmapcache
tst_qquickpixmapcache.cpp
deviceloadingimage.h deviceloadingimage.cpp
LIBRARIES
- Qt::Concurrent
Qt::CorePrivate
Qt::Gui
Qt::GuiPrivate
@@ -48,6 +47,11 @@ qt_internal_extend_target(tst_qquickpixmapcache CONDITION NOT ANDROID AND NOT IO
QT_QMLTEST_DATADIR="${CMAKE_CURRENT_SOURCE_DIR}/data"
)
+qt_internal_extend_target(tst_qquickpixmapcache CONDITION QT_FEATURE_concurrent
+ LIBRARIES
+ Qt::Concurrent
+)
+
qt_policy(SET QTP0001 NEW)
qt_add_qml_module(tst_qquickpixmapcache
URI PixmapCacheTest