aboutsummaryrefslogtreecommitdiffstats
path: root/tests/benchmarks/qml/deltablue/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/benchmarks/qml/deltablue/CMakeLists.txt')
-rw-r--r--tests/benchmarks/qml/deltablue/CMakeLists.txt37
1 files changed, 37 insertions, 0 deletions
diff --git a/tests/benchmarks/qml/deltablue/CMakeLists.txt b/tests/benchmarks/qml/deltablue/CMakeLists.txt
new file mode 100644
index 0000000000..36a682315a
--- /dev/null
+++ b/tests/benchmarks/qml/deltablue/CMakeLists.txt
@@ -0,0 +1,37 @@
+# Copyright (C) 2023 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+qt_internal_add_benchmark(tst_deltablue
+ SOURCES
+ main.cpp
+ LIBRARIES
+ Qt::Qml
+ Qt::Test
+)
+
+
+set_source_files_properties(
+ Main.qml
+ Strength.qml
+ PROPERTIES
+ QT_QML_SINGLETON_TYPE True
+)
+
+qt_add_qml_module(tst_deltablue
+ URI DeltaBlue
+ VERSION 1.0
+ QML_FILES
+ BaseConstraint.qml
+ ChainTest.qml
+ Constraint.qml
+ Main.qml
+ Main2.qml
+ Plan.qml
+ Planner.qml
+ ProjectionTest.qml
+ Satisfaction.qml
+ Strength.qml
+ Variable.qml
+ deltablue.js
+)
+