aboutsummaryrefslogtreecommitdiffstats
path: root/tests/manual/e2e/qml/qmlformat/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/manual/e2e/qml/qmlformat/CMakeLists.txt')
-rw-r--r--tests/manual/e2e/qml/qmlformat/CMakeLists.txt27
1 files changed, 27 insertions, 0 deletions
diff --git a/tests/manual/e2e/qml/qmlformat/CMakeLists.txt b/tests/manual/e2e/qml/qmlformat/CMakeLists.txt
new file mode 100644
index 0000000000..b93b2b6543
--- /dev/null
+++ b/tests/manual/e2e/qml/qmlformat/CMakeLists.txt
@@ -0,0 +1,27 @@
+# Copyright (C) 2024 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+#####################################################################
+## e2e_qmlformat Test:
+#####################################################################
+
+if(NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(tst_qmlformat LANGUAGES CXX)
+ find_package(Qt6BuildInternals REQUIRED COMPONENTS STANDALONE_TEST)
+endif()
+
+qt_internal_add_test(e2e_qmlformat
+ SOURCES
+ e2e_qmlformat.cpp
+ DEFINES
+ SRCDIR="${CMAKE_CURRENT_SOURCE_DIR}"
+ LIBRARIES
+ Qt::Core
+ Qt::QmlDomPrivate
+ Qt::TestPrivate
+ Qt::QuickTestUtilsPrivate
+ TIMEOUT 3000
+)
+
+add_dependencies(e2e_qmlformat Qt::qmlformat)