aboutsummaryrefslogtreecommitdiffstats
path: root/tests/manual/quickcontrols/material/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/manual/quickcontrols/material/CMakeLists.txt')
-rw-r--r--tests/manual/quickcontrols/material/CMakeLists.txt34
1 files changed, 34 insertions, 0 deletions
diff --git a/tests/manual/quickcontrols/material/CMakeLists.txt b/tests/manual/quickcontrols/material/CMakeLists.txt
new file mode 100644
index 0000000000..1cd3a98d0f
--- /dev/null
+++ b/tests/manual/quickcontrols/material/CMakeLists.txt
@@ -0,0 +1,34 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
+if (NOT QT_BUILD_STANDALONE_TESTS AND NOT QT_BUILDING_QT)
+ cmake_minimum_required(VERSION 3.16)
+ project(material LANGUAGES C CXX ASM)
+ find_package(Qt6BuildInternals COMPONENTS STANDALONE_TEST)
+endif()
+
+qt_internal_add_manual_test(material
+ GUI
+ SOURCES
+ material.cpp
+ LIBRARIES
+ Qt::Gui
+ Qt::Qml
+ Qt::QuickControls2
+)
+
+set(qmake_immediate_resource_files
+ "material.qml"
+ "Constants.qml"
+ "pages/ButtonPage.qml"
+ "pages/DelayButtonPage.qml"
+ "pages/RoundButtonPage.qml"
+ "qmldir"
+)
+
+qt_internal_add_resource(material "qmake_immediate"
+ PREFIX
+ "/"
+ FILES
+ ${qmake_immediate_resource_files}
+)