aboutsummaryrefslogtreecommitdiffstats
path: root/tools/qml/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tools/qml/CMakeLists.txt')
-rw-r--r--tools/qml/CMakeLists.txt41
1 files changed, 8 insertions, 33 deletions
diff --git a/tools/qml/CMakeLists.txt b/tools/qml/CMakeLists.txt
index 0bbde6d288..b209c730d3 100644
--- a/tools/qml/CMakeLists.txt
+++ b/tools/qml/CMakeLists.txt
@@ -19,35 +19,18 @@ qt_internal_add_app(qml
set_target_properties(qml PROPERTIES WIN32_EXECUTABLE FALSE)
-set_source_files_properties(
- conf/default.qml
- conf/resizeToItem.qml
- conf/content/resizeItemToWindow.qml
- conf/content/resizeWindowToItem.qml
- PROPERTIES QT_SKIP_QUICKCOMPILER 1
-)
-
-# Resources:
-set(qml_resource_files
- "conf/content/resizeItemToWindow.qml"
- "conf/content/resizeWindowToItem.qml"
- "conf/default.qml"
- "conf/resizeToItem.qml"
- "resources/qml-64.png"
-)
-
-qt_internal_add_resource(qml qml
- PREFIX
- "/qt-project.org/QmlRuntime"
- FILES
- ${qml_resource_files}
-)
-
# Turn the tool into its own self-contained qml module
qt6_add_qml_module(qml
- RESOURCE_PREFIX "/qt-project.org"
+ RESOURCE_PREFIX "/qt-project.org/imports"
URI QmlRuntime.Config
VERSION 1.0
+ QML_FILES
+ default.qml
+ resizeToItem.qml
+ ResizeItemToWindow.qml
+ ResizeWindowToItem.qml
+ RESOURCES
+ resources/qml-64.png
)
qt_internal_extend_target(qml CONDITION TARGET Qt::Gui
@@ -60,14 +43,6 @@ qt_internal_extend_target(qml CONDITION TARGET Qt::Widgets
Qt::Widgets
)
-#### Keys ignored in scope 4:.:.:qml.pro:WIN32:
-# RC_ICONS = "resources/qml.ico"
-
-#### Keys ignored in scope 5:.:.:qml.pro:APPLE:
-# ICON = "resources/qml.icns"
-# OTHER_FILES = "resources/Info.plist"
-# QMAKE_INFO_PLIST = "resources/Info.plist"
-
qt_internal_extend_target(qml CONDITION QT_FEATURE_qml_debug
DEFINES
QT_QML_DEBUG_NO_WARNING