aboutsummaryrefslogtreecommitdiffstats
path: root/tools/qmllint/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tools/qmllint/CMakeLists.txt')
-rw-r--r--tools/qmllint/CMakeLists.txt11
1 files changed, 6 insertions, 5 deletions
diff --git a/tools/qmllint/CMakeLists.txt b/tools/qmllint/CMakeLists.txt
index a133af3cb7..ae3de5901d 100644
--- a/tools/qmllint/CMakeLists.txt
+++ b/tools/qmllint/CMakeLists.txt
@@ -1,3 +1,6 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
# Generated from qmllint.pro.
#####################################################################
@@ -9,15 +12,13 @@ qt_internal_add_tool(${target_name}
TARGET_DESCRIPTION "QML Syntax Verifier"
TOOLS_TARGET Qml # special case
SOURCES
- checkidentifiers.cpp checkidentifiers.h
- findwarnings.cpp findwarnings.h
main.cpp
- qcoloroutput.cpp qcoloroutput.h
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::CorePrivate
Qt::QmlCompilerPrivate
- Qt::QmlDevToolsPrivate
+ Qt::QmlToolingSettingsPrivate
)
+qt_internal_return_unless_building_tools()
#### Keys ignored in scope 1:.:.:qmllint.pro:<TRUE>:
# QMAKE_TARGET_DESCRIPTION = "QML" "Syntax" "Verifier"