aboutsummaryrefslogtreecommitdiffstats
path: root/tools/qmltime/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tools/qmltime/CMakeLists.txt')
-rw-r--r--tools/qmltime/CMakeLists.txt29
1 files changed, 10 insertions, 19 deletions
diff --git a/tools/qmltime/CMakeLists.txt b/tools/qmltime/CMakeLists.txt
index 1486885e33..e3c62e2cf9 100644
--- a/tools/qmltime/CMakeLists.txt
+++ b/tools/qmltime/CMakeLists.txt
@@ -1,3 +1,6 @@
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
+
# Generated from qmltime.pro.
#####################################################################
@@ -10,29 +13,17 @@ qt_internal_add_tool(${target_name}
TOOLS_TARGET Qml # special case
SOURCES
qmltime.cpp qmltime.h
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::Gui
Qt::Qml
Qt::Quick
Qt::QuickPrivate
)
+qt_internal_return_unless_building_tools()
-#### Keys ignored in scope 1:.:.:qmltime.pro:<TRUE>:
-# QMAKE_TARGET_DESCRIPTION = "QML" "Time"
-# QML_IMPORT_NAME = "QmlTime"
-# QML_IMPORT_VERSION = "1.0"
-
-## Scopes:
-#####################################################################
-
-# Don't set properties on a host tool when cross compiling, because it
-# is not being built.
-if(NOT CMAKE_CROSSCOMPILING OR QT_BUILD_TOOLS_WHEN_CROSSCOMPILING)
-
-set_target_properties(${target_name} PROPERTIES
- QT_QML_MODULE_VERSION 1.0
- QT_QML_MODULE_URI QmlTime
+# Turn the tool into its own self-contained qml module
+qt_internal_add_qml_module(${target_name}
+ URI QmlTime
+ VERSION 1.0
+ NO_PLUGIN
)
-qt6_qml_type_registration(${target_name})
-endif()
-