summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2021-06-11 10:30:42 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2021-06-14 14:39:35 +0300
commit10c59319e196f717e569a9a0bfc45ae73d88d1fd (patch)
treea03ef86d9599cd9dcaa847a263ac928218c2cfbc /CMakeLists.txt
parent323d973793cd06b52625b26b6cd8c21e8a443e65 (diff)
CMake: skip build on wasm
... and do some cleanup on the CMake files. Change-Id: I999a76728bb5af1f53a3bde076143febc51d4d2c Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Teemu Holappa <teemu.holappa@qt.io>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt26
1 files changed, 18 insertions, 8 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d5bedf8..5fd523a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,24 +1,34 @@
-# Generated from qtdeviceutilities.pro.
-
cmake_minimum_required(VERSION 3.15.0)
include(.cmake.conf)
-project(QtDeviceUtilities # special case
+project(QtDeviceUtilities
VERSION "${QT_REPO_MODULE_VERSION}"
- DESCRIPTION "Qt Device Utilities Libraries" # special case
+ DESCRIPTION "Qt Device Utilities Libraries"
HOMEPAGE_URL "https://qt.io/"
LANGUAGES CXX C
)
-find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Quick DBus) # special case
-find_package(Qt6 ${PROJECT_VERSION} CONFIG OPTIONAL_COMPONENTS)
+find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals)
+find_package(Qt6 ${PROJECT_VERSION} CONFIG OPTIONAL_COMPONENTS Quick DBus)
+
+macro(assertTargets)
+ foreach(qtTarget IN ITEMS ${ARGN})
+ if(NOT TARGET Qt::${qtTarget})
+ message(NOTICE "Skipping the build as the condition \"TARGET Qt::${qtTarget}\" is not met.")
+ return()
+ endif()
+ endforeach()
+endmacro()
+
+assertTargets(Quick DBus)
if(NOT LINUX)
message(NOTICE "Skipping the build as the condition \"LINUX\" is not met.")
return()
endif()
-if(NOT TARGET Qt::Quick)
- message(NOTICE "Skipping the build as the condition \"TARGET Qt::Quick\" is not met.")
+if(WASM)
+ message(NOTICE "Skipping the build as the condition \"NOT WASM\" is not met.")
return()
endif()
+
qt_build_repo()