summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorTopi Reinio <topi.reinio@qt.io>2021-12-16 13:05:25 +0100
committerTopi Reinio <topi.reinio@qt.io>2021-12-16 13:49:32 +0100
commit3e86b62b6f865e9ed235c7ea676e9ee5b1df21e3 (patch)
tree5bd6d9d33bfeb00538a974fe77bfed5c1d1819b1 /src/CMakeLists.txt
parent4e2ef099713247b751fcab1ea3c87514cf2ea528 (diff)
Doc: Fix CMake build configuration for doc builds
* Add src/doc into the build * Select the correct doc template for online doc builds * Move and update the online sidebar * Fix q QDoc warning in passing Pick-to: 6.3 6.2 Change-Id: Ib40e5e05de337da59b69ce950edf2e9e041af536 Reviewed-by: Nicholas Bennett <nicholas.bennett@qt.io>
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 88e2c48..0e91047 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -1,4 +1,5 @@
add_subdirectory(networksettings)
+add_subdirectory(doc)
if(TARGET Qt::Qml)
add_subdirectory(networksettingsqml)