summaryrefslogtreecommitdiffstats
path: root/src/imports
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2021-06-11 08:22:15 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2021-06-14 14:39:20 +0300
commitfcf3bae3c19623df2f90d53434342b917a6d01bc (patch)
tree8a125e0a9dee5e39d3bb2a7c18de923dcdd2b0a7 /src/imports
parent2ce745192cf637e7418f52457c1cd32198167b66 (diff)
CMake: Update to latest Qt CMake API
Task-number: QTBUG-91621 Fixes: QTBUG-94396 Change-Id: Ieaf5241eeb297a86775bb784c39217eb2b92b1b9 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'src/imports')
-rw-r--r--src/imports/networksettings/CMakeLists.txt16
1 files changed, 7 insertions, 9 deletions
diff --git a/src/imports/networksettings/CMakeLists.txt b/src/imports/networksettings/CMakeLists.txt
index b2b07b8..60f8a64 100644
--- a/src/imports/networksettings/CMakeLists.txt
+++ b/src/imports/networksettings/CMakeLists.txt
@@ -1,14 +1,16 @@
-# Generated from networksettings.pro.
-
#####################################################################
## networksettingsplugin Plugin:
#####################################################################
-qt_add_qml_module(networksettingsplugin
+qt_internal_add_qml_module(networksettingsplugin
URI "QtDeviceUtilities.NetworkSettings"
VERSION "${CMAKE_PROJECT_VERSION}"
- CLASSNAME NetworkSettingsQmlPlugin
- SKIP_TYPE_REGISTRATION
+ CLASS_NAME NetworkSettingsQmlPlugin
+ PLUGIN_TARGET networksettingsplugin
+ NO_GENERATE_PLUGIN_SOURCE
+ NO_PLUGIN_OPTIONAL
+ NO_GENERATE_QMLTYPES
+ INSTALL_SOURCE_QMLTYPES "plugins.qmltypes"
SOURCES
plugin.cpp plugin.h
PUBLIC_LIBRARIES
@@ -18,7 +20,3 @@ qt_add_qml_module(networksettingsplugin
Qt::Quick
Qt::NetworkSettings
)
-
-#### Keys ignored in scope 1:.:.:networksettings.pro:<TRUE>:
-# QML_IMPORT_VERSION = "$$QT_VERSION"
-# TARGETPATH = "QtDeviceUtilities/NetworkSettings"