summaryrefslogtreecommitdiffstats
path: root/src/imports/networksettings/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/imports/networksettings/CMakeLists.txt')
-rw-r--r--src/imports/networksettings/CMakeLists.txt24
1 files changed, 24 insertions, 0 deletions
diff --git a/src/imports/networksettings/CMakeLists.txt b/src/imports/networksettings/CMakeLists.txt
new file mode 100644
index 0000000..0c43a30
--- /dev/null
+++ b/src/imports/networksettings/CMakeLists.txt
@@ -0,0 +1,24 @@
+# Generated from networksettings.pro.
+
+#####################################################################
+## networksettingsplugin Plugin:
+#####################################################################
+
+qt_add_qml_module(networksettingsplugin
+ URI "QtDeviceUtilities.NetworkSettings"
+ VERSION "${CMAKE_PROJECT_VERSION}"
+ CLASSNAME NetworkSettingsQmlPlugin
+ SKIP_TYPE_REGISTRATION
+ SOURCES
+ plugin.cpp plugin.h
+ PUBLIC_LIBRARIES
+ Qt::Core
+ Qt::Gui
+ Qt::Qml
+ Qt::Quick
+ networksettings
+)
+
+#### Keys ignored in scope 1:.:.:networksettings.pro:<TRUE>:
+# QML_IMPORT_VERSION = "$$QT_VERSION"
+# TARGETPATH = "QtDeviceUtilities/NetworkSettings"