aboutsummaryrefslogtreecommitdiffstats
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorSimon Hausmann <simon.hausmann@qt.io>2019-10-23 12:59:34 +0200
committerSimon Hausmann <simon.hausmann@qt.io>2019-10-23 11:08:02 +0000
commit46f75ef4912d2a677bee4b76af1de0b7f4a37f04 (patch)
treef1d18f48759eee61d1d471e2731f659da7861d56 /tests/CMakeLists.txt
parent9fbf7e91201c5cf55a6cf1f15ffc96b2c55332d0 (diff)
Prospective cmake build fix
Find the BuildInternals package in order to find qt_set_up_standalone_tests_build() Change-Id: If7396d5ad1ba873a3fc277dcd1677f185677834d Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index cca08c8..e65ab4b 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -3,7 +3,7 @@
if(NOT TARGET Qt::Test)
cmake_minimum_required(VERSION 3.15.0)
project(QtGraphicalEffectsTests VERSION 6.0.0 LANGUAGES C CXX) # special case
- find_package(Qt6 ${PROJECT_VERSION} REQUIRED COMPONENTS Core Test Qml Quick) # special case
+ find_package(Qt6 ${PROJECT_VERSION} REQUIRED COMPONENTS BuildInternals Core Test Qml Quick) # special case
qt_set_up_standalone_tests_build()
endif()
qt_build_tests()