aboutsummaryrefslogtreecommitdiffstats
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-03-06 17:25:25 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-03-12 14:54:06 +0000
commit7c372c634b9433d21f0bf2653f281f83a7cb334d (patch)
tree105004c18143c559b6420dc8ee09774f74da51cb /tests/CMakeLists.txt
parent936be561e4b2d28b51a1c1a9dae4b7baf1f932e1 (diff)
Regenerate projects
Change-Id: If53bcd94a338c62bf69ed7f74c6a8bc5ff4818ed Reviewed-by: Leander Beernaert <leander.beernaert@qt.io> Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io> Reviewed-by: Liang Qi <liang.qi@qt.io>
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt8
1 files changed, 3 insertions, 5 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index e65ab4b..ed965c0 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -1,10 +1,8 @@
# Generated from tests.pro.
-if(NOT TARGET Qt::Test)
- cmake_minimum_required(VERSION 3.15.0)
- project(QtGraphicalEffectsTests VERSION 6.0.0 LANGUAGES C CXX) # special case
- find_package(Qt6 ${PROJECT_VERSION} REQUIRED COMPONENTS BuildInternals Core Test Qml Quick) # special case
- qt_set_up_standalone_tests_build()
+if(QT_BUILD_STANDALONE_TESTS)
+ # Add qt_find_package calls for extra dependencies that need to be found when building
+ # the standalone tests here.
endif()
qt_build_tests()