summaryrefslogtreecommitdiffstats
path: root/src/plugins/imageformats/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-03-16 17:07:41 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-03-16 18:02:19 +0000
commitc96422ae949b151399be50d606cc40ecfb7e6ddb (patch)
tree688ff72b94eb67d6c0a3d164947c3f040843cdcd /src/plugins/imageformats/CMakeLists.txt
parent51e7fa714ca76fd9edb342fc8e97451086e46fe3 (diff)
CMake: Regenerate and fixup qtimageformats projectswip/cmake
A few changes happened since last update: - CMake target names are now consistent with Qt 5 names - ZLIB handling - TIFF 3rd party handling - Standalone tests simplification - Updates in the SUBDIRS project - Other minor changes Change-Id: I85cca79d38feca44c5b78dae48c79779ae05e288 Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
Diffstat (limited to 'src/plugins/imageformats/CMakeLists.txt')
-rw-r--r--src/plugins/imageformats/CMakeLists.txt11
1 files changed, 4 insertions, 7 deletions
diff --git a/src/plugins/imageformats/CMakeLists.txt b/src/plugins/imageformats/CMakeLists.txt
index 01855f4..6f7cb49 100644
--- a/src/plugins/imageformats/CMakeLists.txt
+++ b/src/plugins/imageformats/CMakeLists.txt
@@ -10,14 +10,12 @@ include(../../imageformats/configure.cmake)
qt_feature_module_end(NO_MODULE)
# special case end
-if(NOT WINRT)
- add_subdirectory(tga)
-endif()
+add_subdirectory(tga)
add_subdirectory(wbmp)
-if(QT_FEATURE_tiff AND NOT WINRT)
+if(QT_FEATURE_tiff)
add_subdirectory(tiff)
endif()
-if(QT_FEATURE_webp AND NOT WINRT)
+if(QT_FEATURE_webp)
add_subdirectory(webp)
endif()
if(APPLE)
@@ -26,7 +24,7 @@ endif()
if(QT_FEATURE_regularexpression)
add_subdirectory(icns)
endif()
-if(QT_FEATURE_mng AND OFF) # special case TODO: FiXME
+if(QT_FEATURE_mng AND OFF) # special case: FIXME
add_subdirectory(mng)
endif()
if(QT_FEATURE_jasper)
@@ -35,4 +33,3 @@ endif()
if(APPLE AND NOT QT_FEATURE_jasper)
add_subdirectory(macjp2)
endif()
-