summaryrefslogtreecommitdiffstats
path: root/tests/auto/heif/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/heif/CMakeLists.txt')
-rw-r--r--tests/auto/heif/CMakeLists.txt20
1 files changed, 7 insertions, 13 deletions
diff --git a/tests/auto/heif/CMakeLists.txt b/tests/auto/heif/CMakeLists.txt
index c4ca92d..3fc310e 100644
--- a/tests/auto/heif/CMakeLists.txt
+++ b/tests/auto/heif/CMakeLists.txt
@@ -1,29 +1,24 @@
-# Generated from heif.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
#####################################################################
## tst_qheif Test:
#####################################################################
-qt_add_test(tst_qheif
+qt_internal_add_test(tst_qheif
SOURCES
tst_qheif.cpp
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::Gui
)
# Resources:
-set_source_files_properties("../../shared/images/heif/col320x480.heic"
- PROPERTIES QT_RESOURCE_ALIAS "heif/col320x480.heic"
-)
-set_source_files_properties("../../shared/images/heif/newlogoCCW.heic"
- PROPERTIES QT_RESOURCE_ALIAS "heif/newlogoCCW.heic"
-)
set(heif_resource_files
- "heif/col320x480.heic"
- "heif/newlogoCCW.heic"
+ "../../shared/images/heif/col320x480.heic"
+ "../../shared/images/heif/newlogoCCW.heic"
)
-qt_add_resource(tst_qheif "heif"
+qt_internal_add_resource(tst_qheif "heif"
PREFIX
"/"
BASE
@@ -31,4 +26,3 @@ qt_add_resource(tst_qheif "heif"
FILES
${heif_resource_files}
)
-