summaryrefslogtreecommitdiffstats
path: root/tests/auto/wbmp/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/wbmp/CMakeLists.txt')
-rw-r--r--tests/auto/wbmp/CMakeLists.txt20
1 files changed, 7 insertions, 13 deletions
diff --git a/tests/auto/wbmp/CMakeLists.txt b/tests/auto/wbmp/CMakeLists.txt
index 09d4cbd..f1392a1 100644
--- a/tests/auto/wbmp/CMakeLists.txt
+++ b/tests/auto/wbmp/CMakeLists.txt
@@ -1,29 +1,24 @@
-# Generated from wbmp.pro.
+# Copyright (C) 2022 The Qt Company Ltd.
+# SPDX-License-Identifier: BSD-3-Clause
#####################################################################
## tst_qwbmp Test:
#####################################################################
-qt_add_test(tst_qwbmp
+qt_internal_add_test(tst_qwbmp
SOURCES
tst_qwbmp.cpp
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::Gui
)
# Resources:
-set_source_files_properties("../../shared/images/wbmp/qt-logo-big.wbmp"
- PROPERTIES QT_RESOURCE_ALIAS "wbmp/qt-logo-big.wbmp"
-)
-set_source_files_properties("../../shared/images/wbmp/qt-logo-small.wbmp"
- PROPERTIES QT_RESOURCE_ALIAS "wbmp/qt-logo-small.wbmp"
-)
set(wbmp_resource_files
- "wbmp/qt-logo-big.wbmp"
- "wbmp/qt-logo-small.wbmp"
+ "../../shared/images/wbmp/qt-logo-big.wbmp"
+ "../../shared/images/wbmp/qt-logo-small.wbmp"
)
-qt_add_resource(tst_qwbmp "wbmp"
+qt_internal_add_resource(tst_qwbmp "wbmp"
PREFIX
"/"
BASE
@@ -31,4 +26,3 @@ qt_add_resource(tst_qwbmp "wbmp"
FILES
${wbmp_resource_files}
)
-