summaryrefslogtreecommitdiffstats
path: root/src/tools/ifcodegen/CMakeLists.txt
diff options
context:
space:
mode:
authorDominik Holland <dominik.holland@qt.io>2024-02-14 16:30:53 +0100
committerDominik Holland <dominik.holland@qt.io>2024-02-14 21:23:10 +0100
commitfbcf503b7872ac0ef5914f5e60fe3dcae5525d4f (patch)
tree425ef80f56583bd69f093052c22dc9a813b33ae9 /src/tools/ifcodegen/CMakeLists.txt
parent9b8124a418f5ac902133652e877181ae414687d9 (diff)
CMake: Rewrite commands which are always executed
Some commands were always executed and caused some things to be rebuild or copied, although there was no need for it. Pick-to: 6.7 Change-Id: I5743bfe540cf67d4df661f7f7a5324f30bed8c93 Reviewed-by: Robert Griebl <robert.griebl@qt.io>
Diffstat (limited to 'src/tools/ifcodegen/CMakeLists.txt')
-rw-r--r--src/tools/ifcodegen/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/src/tools/ifcodegen/CMakeLists.txt b/src/tools/ifcodegen/CMakeLists.txt
index c9a4b9c2..82fa7edb 100644
--- a/src/tools/ifcodegen/CMakeLists.txt
+++ b/src/tools/ifcodegen/CMakeLists.txt
@@ -255,10 +255,14 @@ elseif(QT_FEATURE_python3_virtualenv AND NOT QT_FEATURE_system_qface)
DESTINATION "${ifcodegen_install_dir}"
)
else()
- add_custom_target(copy_virtualenv
+ add_custom_command(OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/.stamp-copy_virtualenv
COMMAND ${CMAKE_COMMAND} -E copy_directory ${VIRTUALENV_PATH} "${ifcodegen_install_dir}/${VIRTUALENV_NAME}"
+ COMMAND ${CMAKE_COMMAND} -E touch .stamp-copy_virtualenv
DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/.stamp-deploy_virtualenv
)
+ add_custom_target(copy_virtualenv ALL
+ DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/.stamp-copy_virtualenv
+ )
add_dependencies(ifcodegen copy_virtualenv)
endif()
endif()