summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c8d8b082..3c6fde74 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -73,6 +73,16 @@ if(IF_COVERAGE)
)
endif()
+if (IF_SANITIZE)
+ if (MSVC)
+ set(ECM_ENABLE_SANITIZERS address)
+ else()
+ set(ECM_ENABLE_SANITIZERS address undefined)
+ endif()
+ include(3rdparty/extra-cmake-modules/modules/ECMEnableSanitizers)
+endif()
+
+
qt_build_repo()
if(NOT QT_BUILD_STANDALONE_TESTS)