summaryrefslogtreecommitdiffstats
path: root/tests/auto/core/ifcodegen/org-example-echo/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/auto/core/ifcodegen/org-example-echo/test/CMakeLists.txt')
-rw-r--r--tests/auto/core/ifcodegen/org-example-echo/test/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/tests/auto/core/ifcodegen/org-example-echo/test/CMakeLists.txt b/tests/auto/core/ifcodegen/org-example-echo/test/CMakeLists.txt
index 8590b177..15beba55 100644
--- a/tests/auto/core/ifcodegen/org-example-echo/test/CMakeLists.txt
+++ b/tests/auto/core/ifcodegen/org-example-echo/test/CMakeLists.txt
@@ -4,7 +4,9 @@ set(CMAKE_AUTOMOC ON)
set(CMAKE_AUTORCC ON)
set(CMAKE_AUTOUIC ON)
-file(TOUCH ${CMAKE_CURRENT_BINARY_DIR}/cmake_dummy.cpp)
+if (NOT EXISTS "${CMAKE_CURRENT_BINARY_DIR}/cmake_dummy.cpp")
+ file(TOUCH ${CMAKE_CURRENT_BINARY_DIR}/cmake_dummy.cpp)
+endif()
qt_internal_add_test(tst_org-example-echo
SOURCES
${CMAKE_CURRENT_BINARY_DIR}/cmake_dummy.cpp