aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorDominik Holland <dominik.holland@qt.io>2021-06-18 13:11:56 +0200
committerDominik Holland <dominik.holland@googlemail.com>2022-01-27 13:50:04 +0100
commit3c1c8b6436f6b621e70ca0b9ab1374c3de392abf (patch)
tree2202d0730b3f1838fa9b6878a2e5ac964710a9ef /setup.py
parent3129feaac52979ddb1daf642a9d6f4656c5ba661 (diff)
Relax the required versions of all our dependencies
This should make it easier to install the package using pip, especially when some other packages require a more uptodate version of one of our dependent packages.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py18
1 files changed, 9 insertions, 9 deletions
diff --git a/setup.py b/setup.py
index d938e09..3a87f8d 100644
--- a/setup.py
+++ b/setup.py
@@ -44,15 +44,15 @@ setup(
packages=find_packages(),
include_package_data=True,
install_requires=[
- 'click==6.7',
- 'antlr4-python3-runtime==4.7.1',
- 'jinja2==2.11.3',
- 'path.py==11.0.1',
- 'pyyaml==5.4',
- 'typing==3.6.4',
- 'watchdog==0.8.3',
- 'six==1.11.0',
- 'coloredlogs==10.0',
+ 'click>=6.7',
+ 'antlr4-python3-runtime>=4.7.1',
+ 'jinja2>=2.11.3',
+ 'path.py>=11.0.1',
+ 'pyyaml>=5.4',
+ 'typing>=3.6.4',
+ 'watchdog>=0.8.3',
+ 'six>=1.11.0',
+ 'coloredlogs>=10.0',
],
extras_require={
'dev': [