aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-02-15 23:11:38 +0100
committerUrs Fleisch <ufleisch@users.sourceforge.net>2021-03-06 14:52:25 +0100
commit01348fb619c669aa26a81a28ce71b010455c78da (patch)
treeb44a0d03463a41e594325f8c24cefe3c4737ddd2 /CMakeLists.txt
parent9e0a7f7adbba91680f9a7615c458954b037bf85d (diff)
Move finding ZLIB to root CMakeLists.txt
Small line decrease, but also easier to read what is happening. Now all dependencies can be read from the root CMakeLists.txt file. Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt22
1 files changed, 15 insertions, 7 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 770fa046..e537aeb3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -101,8 +101,21 @@ math(EXPR TAGLIB_SOVERSION_PATCH "${TAGLIB_SOVERSION_REVISION}")
include(ConfigureChecks.cmake)
-if(${ZLIB_FOUND})
- set(ZLIB_LIBRARIES_FLAGS -lz)
+# Determine whether zlib is installed.
+
+if(NOT ZLIB_SOURCE)
+ find_package(ZLIB)
+ if(ZLIB_FOUND)
+ set(HAVE_ZLIB 1)
+ set(ZLIB_LIBRARIES_FLAGS -lz)
+ else()
+ set(HAVE_ZLIB 0)
+ endif()
+endif()
+
+if(NOT HAVE_ZLIB AND ZLIB_SOURCE)
+ set(HAVE_ZLIB 1)
+ set(HAVE_ZLIB_SOURCE 1)
endif()
if(NOT WIN32)
@@ -120,11 +133,6 @@ if(NOT BUILD_FRAMEWORK)
install(FILES "${CMAKE_CURRENT_BINARY_DIR}/taglib.pc" DESTINATION "${LIB_INSTALL_DIR}/pkgconfig")
endif()
-if(NOT HAVE_ZLIB AND ZLIB_SOURCE)
- set(HAVE_ZLIB 1)
- set(HAVE_ZLIB_SOURCE 1)
-endif()
-
include_directories(${CMAKE_CURRENT_BINARY_DIR})
configure_file(config.h.cmake "${CMAKE_CURRENT_BINARY_DIR}/config.h")