aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorg-coder <garima.g@samsung.com>2015-11-26 15:12:23 +0530
committerg-coder <garima.g@samsung.com>2015-11-26 15:12:23 +0530
commit14f3b6c928c9e2843a34c63bd5abbac5eee35d46 (patch)
tree3d6a1e32b13d84ec888d019f569685820065ac30 /CMakeLists.txt
parent66dd0b8a6fd750a9e137137773bbcb24b3a7636f (diff)
Added ccache support for faster compilation
ccache is a compiler cache. It speeds up recompilation by caching previous compilations and detecting when the same compilation is being done again. It provides support for C/C++ languages. It makes compilation fast if it is available on the machine. https://ccache.samba.org/
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2fe1dadb..27c146a9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -137,6 +137,12 @@ configure_file("${CMAKE_CURRENT_SOURCE_DIR}/Doxyfile.cmake" "${CMAKE_CURRENT_BIN
file(COPY doc/taglib.png DESTINATION doc)
add_custom_target(docs doxygen)
+find_program(CCACHE_FOUND ccache)
+if(CCACHE_FOUND)
+ set_property(GLOBAL PROPERTY RULE_LAUNCH_COMPILE ccache)
+ set_property(GLOBAL PROPERTY RULE_LAUNCH_LINK ccache)
+endif(CCACHE_FOUND)
+
# uninstall target
configure_file(
"${CMAKE_CURRENT_SOURCE_DIR}/cmake_uninstall.cmake.in"