aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPeter Petrovich <petro@petro.ws>2015-08-05 08:45:27 +0300
committerPeter Petrovich <petro@petro.ws>2015-08-05 08:45:27 +0300
commit46e74c93912c2058bbb125de50ed1dfab837d01d (patch)
tree6ba686ba733c98a590148499d7577414c2839061 /CMakeLists.txt
parent7c17d32b3a8bc3ed718af3790452fec33ebd307b (diff)
Install target check fix
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bbaa3aa3..4bde0d0a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -127,5 +127,7 @@ configure_file(
"${CMAKE_CURRENT_BINARY_DIR}/cmake_uninstall.cmake"
IMMEDIATE @ONLY)
-add_custom_target(uninstall
+if (NOT TARGET uninstall)
+ add_custom_target(uninstall
COMMAND "${CMAKE_COMMAND}" -P "${CMAKE_CURRENT_BINARY_DIR}/cmake_uninstall.cmake")
+endif() \ No newline at end of file