aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorevpobr <evpobr@gmail.com>2018-10-27 05:26:53 +0500
committerStephen F. Booth <me@sbooth.org>2018-10-26 19:26:53 -0500
commitbfed3797a0c33abdf396dd19007f9f640535ac56 (patch)
tree984fa50b633e54aa4bcff5fb60fbc580cc9836e5 /CMakeLists.txt
parente43537214600edf854157c54cc4f687b076631b8 (diff)
Improve CMake VISIBILITY_HIDDEN option handling (#810)
Use standard CMake's CXX_VISIBILITY_PRESET property.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 0 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3e081ea2..2de06324 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -36,10 +36,6 @@ if(ENABLE_CCACHE)
endif()
option(VISIBILITY_HIDDEN "Build with -fvisibility=hidden" OFF)
-if(VISIBILITY_HIDDEN)
- add_definitions(-fvisibility=hidden)
-endif()
-
option(BUILD_TESTS "Build the test suite" OFF)
option(BUILD_EXAMPLES "Build the examples" OFF)
option(BUILD_BINDINGS "Build the bindings" ON)