aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTsuda Kageyu <tsuda.kageyu@gmail.com>2015-11-12 14:41:15 +0900
committerTsuda Kageyu <tsuda.kageyu@gmail.com>2015-11-12 14:41:15 +0900
commitc66e6b27d9658aa1a1a5984ec3caf2420bcedf29 (patch)
tree9602779ffd333e1158462f0ccfa9559800d64fbe /CMakeLists.txt
parent1d379fdb2f8703f94106001656c60db57d259700 (diff)
Small cleanups in CMakeLists.txt.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 6 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f2455a79..88674bb9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -38,15 +38,15 @@ set(LIB_INSTALL_DIR "${EXEC_INSTALL_PREFIX}/lib${LIB_SUFFIX}" CACHE PATH "The su
set(INCLUDE_INSTALL_DIR "${CMAKE_INSTALL_PREFIX}/include" CACHE PATH "The subdirectory to the header prefix" FORCE)
if(APPLE)
- option(BUILD_FRAMEWORK "Build an OS X framework" OFF)
- set(FRAMEWORK_INSTALL_DIR "/Library/Frameworks" CACHE STRING "Directory to install frameworks to.")
+ option(BUILD_FRAMEWORK "Build an OS X framework" OFF)
+ set(FRAMEWORK_INSTALL_DIR "/Library/Frameworks" CACHE STRING "Directory to install frameworks to.")
endif()
if(CMAKE_COMPILER_IS_GNUCC OR CMAKE_COMPILER_IS_GNUCXX)
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall")
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall")
endif()
-if (MSVC AND ENABLE_STATIC_RUNTIME)
+if(MSVC AND ENABLE_STATIC_RUNTIME)
foreach(flag_var CMAKE_CXX_FLAGS CMAKE_CXX_FLAGS_DEBUG CMAKE_CXX_FLAGS_RELEASE CMAKE_CXX_FLAGS_MINSIZEREL CMAKE_CXX_FLAGS_RELWITHDEBINFO)
string(REGEX REPLACE "/MD" "/MT" ${flag_var} "${${flag_var}}")
endforeach(flag_var)
@@ -116,8 +116,8 @@ configure_file(taglib/taglib_config.h.cmake "${CMAKE_CURRENT_BINARY_DIR}/taglib_
add_subdirectory(taglib)
add_subdirectory(bindings)
if(BUILD_TESTS)
- enable_testing()
- add_subdirectory(tests)
+ enable_testing()
+ add_subdirectory(tests)
endif(BUILD_TESTS)
add_subdirectory(examples)
@@ -131,7 +131,7 @@ configure_file(
"${CMAKE_CURRENT_BINARY_DIR}/cmake_uninstall.cmake"
IMMEDIATE @ONLY)
-if (NOT TARGET uninstall)
+if(NOT TARGET uninstall)
add_custom_target(uninstall
COMMAND "${CMAKE_COMMAND}" -P "${CMAKE_CURRENT_BINARY_DIR}/cmake_uninstall.cmake")
endif()