aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFestus Hagen <festushagen2002@yahoo.com>2016-08-25 15:03:44 -0400
committerFestus Hagen <festushagen2002@yahoo.com>2016-08-25 15:03:44 -0400
commitc9bdd416efb5e46c8180b934985bd98adc4c2180 (patch)
tree3d8cb0d54a4771804b855dd0ca2224c46dabeff5 /CMakeLists.txt
parent92c070ba9e2439128e81b6f643bee7d235648cb4 (diff)
Add BUILD_SHARED_LIBS option for CMake GUI.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 298ee7e3..dc7e4890 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -12,6 +12,7 @@ if(DEFINED ENABLE_STATIC)
message(FATAL_ERROR "This option is no longer available, use BUILD_SHARED_LIBS instead")
endif()
+option(BUILD_SHARED_LIBS "Build shared libraries" OFF)
if(NOT BUILD_SHARED_LIBS)
add_definitions(-DTAGLIB_STATIC)
endif()