aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorScott Wheeler <scott@directededge.com>2019-09-10 12:41:11 +0200
committerScott Wheeler <scott@directededge.com>2019-09-10 12:41:11 +0200
commitef1312d62239f399c40233d76ef3328b8dadf984 (patch)
tree192869d897726eb38372b8ebce2d35a3df8b2936 /CMakeLists.txt
parent86c042847571db0bdfa8dbb6093a30d4ff03be11 (diff)
Add -lz to taglib.pc and taglib-config when built with zlib
Closes #872
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1a0302c4..3d2470c6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -104,6 +104,10 @@ math(EXPR TAGLIB_SOVERSION_PATCH "${TAGLIB_SOVERSION_REVISION}")
include(ConfigureChecks.cmake)
+if(${ZLIB_FOUND})
+ set(ZLIB_LIBRARIES_FLAGS -lz)
+endif()
+
if(NOT WIN32)
configure_file("${CMAKE_CURRENT_SOURCE_DIR}/taglib-config.cmake" "${CMAKE_CURRENT_BINARY_DIR}/taglib-config" @ONLY)
install(PROGRAMS "${CMAKE_CURRENT_BINARY_DIR}/taglib-config" DESTINATION "${BIN_INSTALL_DIR}")