aboutsummaryrefslogtreecommitdiffstats
path: root/examples/ivicore/qface-tutorial/chapter4-simulation-behavior/frontend/CMakeLists.txt
diff options
context:
space:
mode:
authorDominik Holland <dominik.holland@qt.io>2020-11-17 12:27:36 +0100
committerDominik Holland <dominik.holland@qt.io>2021-03-26 11:02:46 +0100
commit3fdd3573f716b044824e11dcd1cabb8442ffeea8 (patch)
tree4f39b967a2aa2ee23daf70bc5ab6d83c1bfb862c /examples/ivicore/qface-tutorial/chapter4-simulation-behavior/frontend/CMakeLists.txt
parent9516ab95f0aac46df99323f3f8d1d7c5ac38365a (diff)
cmake: Start of cmake port using run_pro2cmake.py and friends
Some special cases are already addressed. Task-number: AUTOSUITE-1633 Change-Id: I5409522c1c5eb76b8aac3e7e332d1e1cc27e594f Reviewed-by: Robert Griebl <robert.griebl@qt.io>
Diffstat (limited to 'examples/ivicore/qface-tutorial/chapter4-simulation-behavior/frontend/CMakeLists.txt')
-rw-r--r--examples/ivicore/qface-tutorial/chapter4-simulation-behavior/frontend/CMakeLists.txt46
1 files changed, 46 insertions, 0 deletions
diff --git a/examples/ivicore/qface-tutorial/chapter4-simulation-behavior/frontend/CMakeLists.txt b/examples/ivicore/qface-tutorial/chapter4-simulation-behavior/frontend/CMakeLists.txt
new file mode 100644
index 0000000..6ee4d49
--- /dev/null
+++ b/examples/ivicore/qface-tutorial/chapter4-simulation-behavior/frontend/CMakeLists.txt
@@ -0,0 +1,46 @@
+# Generated from frontend.pro.
+
+cmake_minimum_required(VERSION 3.14)
+project(QtIviInstrumentCluster LANGUAGES CXX)
+
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+
+if(NOT DEFINED INSTALL_EXAMPLESDIR)
+ set(INSTALL_EXAMPLESDIR "examples")
+endif()
+
+set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/ivicore/qface-tutorial/chapter4-simulation-behavior")
+
+find_package(Qt6 COMPONENTS Core)
+find_package(Qt6 COMPONENTS Gui)
+find_package(Qt6 COMPONENTS IviCore)
+find_package(Qt6 COMPONENTS Qml)
+find_package(Qt6 COMPONENTS Quick)
+
+)
+set_target_properties(QtIviInstrumentCluster PROPERTIES
+ WIN32_EXECUTABLE TRUE
+ MACOSX_BUNDLE TRUE
+)
+target_compile_definitions(QtIviInstrumentCluster PUBLIC
+ QT_BUILD_EXAMPLE_IVI_INSTRUMENTCLUSTER_LIB
+)
+
+target_link_libraries(QtIviInstrumentCluster PUBLIC
+ Qt::Core
+ Qt::Gui
+ Qt::IviCore
+ Qt::IviCorePrivate
+ Qt::Qml
+ Qt::Quick
+)
+
+install(TARGETS QtIviInstrumentCluster
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
+ LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
+)