aboutsummaryrefslogtreecommitdiffstats
path: root/examples/ivicore/qface-tutorial/chapter4-simulation-behavior/imports/CMakeLists.txt
diff options
context:
space:
mode:
authorDominik Holland <dominik.holland@qt.io>2021-05-11 14:22:17 +0200
committerDominik Holland <dominik.holland@qt.io>2021-05-20 15:23:38 +0200
commit2d2d4e0cdaec8dbb6e8612f4d408d247ea57f993 (patch)
tree580be7366e716b5eb5e22ccc6059791f1cde1685 /examples/ivicore/qface-tutorial/chapter4-simulation-behavior/imports/CMakeLists.txt
parent3378986c6345587fbc55c9fb6e145bfa511095d3 (diff)
Enable the QtRemoteObjects support
Similar to the previous commits, the examples and tests build ok, but are not yet ready to be used and still need to be refactored. Change-Id: Icb4482696e81a5a17b89622182053c5cfcb5fc7b Reviewed-by: Robert Griebl <robert.griebl@qt.io>
Diffstat (limited to 'examples/ivicore/qface-tutorial/chapter4-simulation-behavior/imports/CMakeLists.txt')
-rw-r--r--examples/ivicore/qface-tutorial/chapter4-simulation-behavior/imports/CMakeLists.txt12
1 files changed, 6 insertions, 6 deletions
diff --git a/examples/ivicore/qface-tutorial/chapter4-simulation-behavior/imports/CMakeLists.txt b/examples/ivicore/qface-tutorial/chapter4-simulation-behavior/imports/CMakeLists.txt
index b55a4e8..8a99af1 100644
--- a/examples/ivicore/qface-tutorial/chapter4-simulation-behavior/imports/CMakeLists.txt
+++ b/examples/ivicore/qface-tutorial/chapter4-simulation-behavior/imports/CMakeLists.txt
@@ -21,26 +21,26 @@ find_package(Qt6 COMPONENTS IviCore)
# IVI Generator:
-qt6_ivigenerator(instrument_cluster_imports # special case
+qt6_ivigenerator(instrument_cluster_chapter4_imports # special case
QFACE_SOURCES ../instrument-cluster.qface
QFACE_FORMAT qmlplugin
)
-set_target_properties(instrument_cluster_imports PROPERTIES # special case
+set_target_properties(instrument_cluster_chapter4_imports PROPERTIES # special case
WIN32_EXECUTABLE TRUE
MACOSX_BUNDLE TRUE
)
-target_include_directories(instrument_cluster_imports PUBLIC # special case
+target_include_directories(instrument_cluster_chapter4_imports PUBLIC # special case
${CMAKE_CURRENT_BINARY_DIR}/../frontend
)
-target_link_libraries(instrument_cluster_imports PUBLIC # special case
- # Remove: L${CMAKE_CURRENT_BINARY_DIR}/../
+target_link_libraries(instrument_cluster_chapter4_imports PUBLIC # special case
+ QtIviInstrumentCluster_Chapter4
Qt::Core
Qt::Gui
Qt::IviCore
)
-install(TARGETS instrument_cluster_imports # special case
+install(TARGETS instrument_cluster_chapter4_imports # special case
RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"