aboutsummaryrefslogtreecommitdiffstats
path: root/examples/ivicore/qface-tutorial/chapter5-ipc/imports/CMakeLists.txt
diff options
context:
space:
mode:
authorDominik Holland <dominik.holland@qt.io>2021-02-17 17:34:35 +0100
committerDominik Holland <dominik.holland@qt.io>2021-05-10 17:28:11 +0200
commit8e3d637e7776638149119bd62f459178cbca2955 (patch)
tree077f7a597039a05555da2c2fe33c1535227dd35e /examples/ivicore/qface-tutorial/chapter5-ipc/imports/CMakeLists.txt
parenteac2590d4266e234f0f2ec4d261d940b14dd79bf (diff)
cmake integration of the ivigenerator
Rerun pro2cmake.py for all examples and tests. Ivigenerator based tests and examples are compiling fine, but the cmake files need to be reworked to be also able to run them. Task-number: AUTOSUITE-1633 Change-Id: Icb95ecfa62ecb319d042dc30ea9f643b69a4aacf Reviewed-by: Robert Griebl <robert.griebl@qt.io>
Diffstat (limited to 'examples/ivicore/qface-tutorial/chapter5-ipc/imports/CMakeLists.txt')
-rw-r--r--examples/ivicore/qface-tutorial/chapter5-ipc/imports/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/examples/ivicore/qface-tutorial/chapter5-ipc/imports/CMakeLists.txt b/examples/ivicore/qface-tutorial/chapter5-ipc/imports/CMakeLists.txt
index 03b4cc9..768b549 100644
--- a/examples/ivicore/qface-tutorial/chapter5-ipc/imports/CMakeLists.txt
+++ b/examples/ivicore/qface-tutorial/chapter5-ipc/imports/CMakeLists.txt
@@ -19,6 +19,11 @@ find_package(Qt6 COMPONENTS Core)
find_package(Qt6 COMPONENTS Gui)
find_package(Qt6 COMPONENTS IviCore)
+
+# IVI Generator:
+qt6_ivigenerator(imports
+ QFACE_SOURCES ../instrument-cluster.qface
+ QFACE_FORMAT qmlplugin
)
set_target_properties(imports PROPERTIES
WIN32_EXECUTABLE TRUE