aboutsummaryrefslogtreecommitdiffstats
path: root/examples/ivicore/qface-tutorial/chapter6-own-backend/frontend/CMakeLists.txt
diff options
context:
space:
mode:
authorDominik Holland <dominik.holland@qt.io>2021-05-11 14:22:17 +0200
committerDominik Holland <dominik.holland@qt.io>2021-05-20 15:23:38 +0200
commit2d2d4e0cdaec8dbb6e8612f4d408d247ea57f993 (patch)
tree580be7366e716b5eb5e22ccc6059791f1cde1685 /examples/ivicore/qface-tutorial/chapter6-own-backend/frontend/CMakeLists.txt
parent3378986c6345587fbc55c9fb6e145bfa511095d3 (diff)
Enable the QtRemoteObjects support
Similar to the previous commits, the examples and tests build ok, but are not yet ready to be used and still need to be refactored. Change-Id: Icb4482696e81a5a17b89622182053c5cfcb5fc7b Reviewed-by: Robert Griebl <robert.griebl@qt.io>
Diffstat (limited to 'examples/ivicore/qface-tutorial/chapter6-own-backend/frontend/CMakeLists.txt')
-rw-r--r--examples/ivicore/qface-tutorial/chapter6-own-backend/frontend/CMakeLists.txt12
1 files changed, 6 insertions, 6 deletions
diff --git a/examples/ivicore/qface-tutorial/chapter6-own-backend/frontend/CMakeLists.txt b/examples/ivicore/qface-tutorial/chapter6-own-backend/frontend/CMakeLists.txt
index 2b0fc93..4654fff 100644
--- a/examples/ivicore/qface-tutorial/chapter6-own-backend/frontend/CMakeLists.txt
+++ b/examples/ivicore/qface-tutorial/chapter6-own-backend/frontend/CMakeLists.txt
@@ -21,22 +21,22 @@ find_package(Qt6 COMPONENTS IviCore)
find_package(Qt6 COMPONENTS Qml)
find_package(Qt6 COMPONENTS Quick)
-qt_add_executable(QtIviInstrumentCluster)
+add_library(QtIviInstrumentCluster_Chapter6)
# IVI Generator:
-qt6_ivigenerator(QtIviInstrumentCluster
+qt6_ivigenerator(QtIviInstrumentCluster_Chapter6
QFACE_SOURCES ../instrument-cluster.qface
QFACE_FORMAT frontend
)
-set_target_properties(QtIviInstrumentCluster PROPERTIES
+set_target_properties(QtIviInstrumentCluster_Chapter6 PROPERTIES
WIN32_EXECUTABLE TRUE
MACOSX_BUNDLE TRUE
)
-target_compile_definitions(QtIviInstrumentCluster PUBLIC
+target_compile_definitions(QtIviInstrumentCluster_Chapter6 PUBLIC
QT_BUILD_EXAMPLE_IVI_INSTRUMENTCLUSTER_LIB
)
-target_link_libraries(QtIviInstrumentCluster PUBLIC
+target_link_libraries(QtIviInstrumentCluster_Chapter6 PUBLIC
Qt::Core
Qt::Gui
Qt::IviCore
@@ -45,7 +45,7 @@ target_link_libraries(QtIviInstrumentCluster PUBLIC
Qt::Quick
)
-install(TARGETS QtIviInstrumentCluster
+install(TARGETS QtIviInstrumentCluster_Chapter6
RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"