aboutsummaryrefslogtreecommitdiffstats
path: root/src/imports/core/CMakeLists.txt
diff options
context:
space:
mode:
authorJoerg Bornemann <joerg.bornemann@qt.io>2021-05-25 15:14:38 +0200
committerDominik Holland <dominik.holland@qt.io>2021-05-26 12:11:07 +0200
commitf357bb6e64ea24e4ec27b6d84c94c3a6dadc24fa (patch)
treef8fe67b7ea4e609f0f16ddcdbed5c636f9bd5966 /src/imports/core/CMakeLists.txt
parentc09bcfbdf0232f8b827fc2a4dd19ca433a62df5f (diff)
CMake: Disable usage of CMake API compatibility wrappers
Setting the QT_NO_INTERNAL_COMPATIBILITY_FUNCTIONS variable in the project ensures we ported away from old API calls. Task-number: QTBUG-86815 Change-Id: I7f86da0411b4870b1a9f9e1ed0b63cf30ccd48ad Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Dominik Holland <dominik.holland@qt.io>
Diffstat (limited to 'src/imports/core/CMakeLists.txt')
-rw-r--r--src/imports/core/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/imports/core/CMakeLists.txt b/src/imports/core/CMakeLists.txt
index cfdd228..7029cc4 100644
--- a/src/imports/core/CMakeLists.txt
+++ b/src/imports/core/CMakeLists.txt
@@ -4,7 +4,7 @@
## qtivicoreplugin Plugin:
#####################################################################
-qt_add_qml_module(qtivicoreplugin
+qt_internal_add_qml_module(qtivicoreplugin
URI "QtIvi"
VERSION "1.0"
CLASSNAME QtIviCorePlugin