aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/ivivehiclefunctions/vehiclefunctions_simulator/CMakeLists.txt
diff options
context:
space:
mode:
authorDominik Holland <dominik.holland@qt.io>2020-11-17 12:27:36 +0100
committerDominik Holland <dominik.holland@qt.io>2021-03-26 11:02:46 +0100
commit3fdd3573f716b044824e11dcd1cabb8442ffeea8 (patch)
tree4f39b967a2aa2ee23daf70bc5ab6d83c1bfb862c /src/plugins/ivivehiclefunctions/vehiclefunctions_simulator/CMakeLists.txt
parent9516ab95f0aac46df99323f3f8d1d7c5ac38365a (diff)
cmake: Start of cmake port using run_pro2cmake.py and friends
Some special cases are already addressed. Task-number: AUTOSUITE-1633 Change-Id: I5409522c1c5eb76b8aac3e7e332d1e1cc27e594f Reviewed-by: Robert Griebl <robert.griebl@qt.io>
Diffstat (limited to 'src/plugins/ivivehiclefunctions/vehiclefunctions_simulator/CMakeLists.txt')
-rw-r--r--src/plugins/ivivehiclefunctions/vehiclefunctions_simulator/CMakeLists.txt36
1 files changed, 36 insertions, 0 deletions
diff --git a/src/plugins/ivivehiclefunctions/vehiclefunctions_simulator/CMakeLists.txt b/src/plugins/ivivehiclefunctions/vehiclefunctions_simulator/CMakeLists.txt
new file mode 100644
index 0000000..71ab87d
--- /dev/null
+++ b/src/plugins/ivivehiclefunctions/vehiclefunctions_simulator/CMakeLists.txt
@@ -0,0 +1,36 @@
+# Generated from vehiclefunctions_simulator.pro.
+
+#####################################################################
+## QtIviVehicleFunctionsSimulatorPlugin Plugin:
+#####################################################################
+
+qt_internal_add_plugin(QtIviVehicleFunctionsSimulatorPlugin
+ OUTPUT_NAME vehiclefunction_simulator
+ TYPE qtivi
+ PUBLIC_LIBRARIES
+ Qt::Core
+ Qt::IviCore
+ ivivehiclefunctions
+)
+
+# Resources:
+set(qml_resource_files
+ "QIviConcreteWindowControlSimulation.qml"
+ "simulation.qml"
+)
+
+qt_internal_add_resource(QtIviVehicleFunctionsSimulatorPlugin "qml"
+ PREFIX
+ "/simulation"
+ FILES
+ ${qml_resource_files}
+)
+
+
+#### Keys ignored in scope 1:.:.:vehiclefunctions_simulator.pro:<TRUE>:
+# CMAKE_MODULE_TESTS = "'-'"
+# PLUGIN_EXTENDS = "ivivehiclefunctions"
+# QFACE_FORMAT = "backend_simulator"
+# QFACE_MODULE_NAME = "QtIviVehicleFunctions"
+# QFACE_SOURCES = "../../../ivivehiclefunctions/ivivehiclefunctions.qface"
+# QML_IMPORT_PATH = "$$OUT_PWD/qml"