aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/core/ivigenerator/projects/org-example-echo-noannotation/backend_simulator/CMakeLists.txt
diff options
context:
space:
mode:
authorDominik Holland <dominik.holland@qt.io>2020-11-17 12:27:36 +0100
committerDominik Holland <dominik.holland@qt.io>2021-03-26 11:02:46 +0100
commit3fdd3573f716b044824e11dcd1cabb8442ffeea8 (patch)
tree4f39b967a2aa2ee23daf70bc5ab6d83c1bfb862c /tests/auto/core/ivigenerator/projects/org-example-echo-noannotation/backend_simulator/CMakeLists.txt
parent9516ab95f0aac46df99323f3f8d1d7c5ac38365a (diff)
cmake: Start of cmake port using run_pro2cmake.py and friends
Some special cases are already addressed. Task-number: AUTOSUITE-1633 Change-Id: I5409522c1c5eb76b8aac3e7e332d1e1cc27e594f Reviewed-by: Robert Griebl <robert.griebl@qt.io>
Diffstat (limited to 'tests/auto/core/ivigenerator/projects/org-example-echo-noannotation/backend_simulator/CMakeLists.txt')
-rw-r--r--tests/auto/core/ivigenerator/projects/org-example-echo-noannotation/backend_simulator/CMakeLists.txt25
1 files changed, 25 insertions, 0 deletions
diff --git a/tests/auto/core/ivigenerator/projects/org-example-echo-noannotation/backend_simulator/CMakeLists.txt b/tests/auto/core/ivigenerator/projects/org-example-echo-noannotation/backend_simulator/CMakeLists.txt
new file mode 100644
index 0000000..81c7410
--- /dev/null
+++ b/tests/auto/core/ivigenerator/projects/org-example-echo-noannotation/backend_simulator/CMakeLists.txt
@@ -0,0 +1,25 @@
+# Generated from backend_simulator.pro.
+
+#####################################################################
+## echo_noannotation_simulator Generic Library:
+#####################################################################
+
+qt_add_cmake_library(echo_noannotation_simulator
+ MODULE
+ OUTPUT_DIRECTORY "${CMAKE_CURRENT_BINARY_DIR}/../qtivi"
+ INCLUDE_DIRECTORIES
+ ${CMAKE_CURRENT_BINARY_DIR}/../frontend
+ PUBLIC_LIBRARIES
+ # Remove: L${CMAKE_CURRENT_BINARY_DIR}/..
+ Qt::Core
+ Qt::Gui
+ Qt::IviCore
+)
+qt_disable_warnings(echo_noannotation_simulator)
+
+#### Keys ignored in scope 1:.:.:backend_simulator.pro:<TRUE>:
+# QFACE_FORMAT = "backend_simulator"
+# QFACE_SOURCES = "../../../org.example.echo.noannotation.qface"
+# TEMPLATE = "lib"
+
+qt_autogen_tools_initial_setup(echo_noannotation_simulator)