aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/core/ivigenerator/projects/org-example-echo-noannotation/test/CMakeLists.txt
diff options
context:
space:
mode:
authorDominik Holland <dominik.holland@qt.io>2021-02-17 17:34:35 +0100
committerDominik Holland <dominik.holland@qt.io>2021-05-10 17:28:11 +0200
commit8e3d637e7776638149119bd62f459178cbca2955 (patch)
tree077f7a597039a05555da2c2fe33c1535227dd35e /tests/auto/core/ivigenerator/projects/org-example-echo-noannotation/test/CMakeLists.txt
parenteac2590d4266e234f0f2ec4d261d940b14dd79bf (diff)
cmake integration of the ivigenerator
Rerun pro2cmake.py for all examples and tests. Ivigenerator based tests and examples are compiling fine, but the cmake files need to be reworked to be also able to run them. Task-number: AUTOSUITE-1633 Change-Id: Icb95ecfa62ecb319d042dc30ea9f643b69a4aacf Reviewed-by: Robert Griebl <robert.griebl@qt.io>
Diffstat (limited to 'tests/auto/core/ivigenerator/projects/org-example-echo-noannotation/test/CMakeLists.txt')
-rw-r--r--tests/auto/core/ivigenerator/projects/org-example-echo-noannotation/test/CMakeLists.txt37
1 files changed, 21 insertions, 16 deletions
diff --git a/tests/auto/core/ivigenerator/projects/org-example-echo-noannotation/test/CMakeLists.txt b/tests/auto/core/ivigenerator/projects/org-example-echo-noannotation/test/CMakeLists.txt
index 558abf5..2cd08aa 100644
--- a/tests/auto/core/ivigenerator/projects/org-example-echo-noannotation/test/CMakeLists.txt
+++ b/tests/auto/core/ivigenerator/projects/org-example-echo-noannotation/test/CMakeLists.txt
@@ -1,21 +1,26 @@
# Generated from test.pro.
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
-#####################################################################
-## tst_org-example-echo-noannotation Test:
-#####################################################################
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
-qt_add_test(tst_org-example-echo-noannotation
- OUTPUT_DIRECTORY "${CMAKE_CURRENT_BINARY_DIR}/../"
- INCLUDE_DIRECTORIES
- ${CMAKE_CURRENT_BINARY_DIR}/../frontend
- PUBLIC_LIBRARIES
- # Remove: L${CMAKE_CURRENT_BINARY_DIR}/..
- Qt::Gui
- Qt::IviCore
+qt_add_executable(tst_org-example-echo-noanno)
+
+# IVI Generator:
+qt6_ivigenerator(tst_org-example-echo-noanno
+ QFACE_SOURCES ../../../org.example.echo.noannotation.qface
+ QFACE_FORMAT test
+)
+set_target_properties(tst_org-example-echo-noanno PROPERTIES
+ WIN32_EXECUTABLE TRUE
+ MACOSX_BUNDLE TRUE
)
-#### Keys ignored in scope 1:.:.:test.pro:<TRUE>:
-# QFACE_FORMAT = "test"
-# QFACE_SOURCES = "../../../org.example.echo.noannotation.qface"
-# QMAKE_PROJECT_NAME = "$$TARGET"
-# QMAKE_RPATHDIR = "$$OUT_PWD/.."
+target_link_libraries(tst_org-example-echo-noanno PUBLIC
+ echo_noanno_frontend
+ Qt::Core
+ Qt::Gui
+ Qt::IviCore
+ Qt::Test
+)