aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/core/ivigenerator/projects/org-example-echo-noprivate/frontend/CMakeLists.txt
diff options
context:
space:
mode:
authorDominik Holland <dominik.holland@qt.io>2021-02-17 17:34:35 +0100
committerDominik Holland <dominik.holland@qt.io>2021-05-10 17:28:11 +0200
commit8e3d637e7776638149119bd62f459178cbca2955 (patch)
tree077f7a597039a05555da2c2fe33c1535227dd35e /tests/auto/core/ivigenerator/projects/org-example-echo-noprivate/frontend/CMakeLists.txt
parenteac2590d4266e234f0f2ec4d261d940b14dd79bf (diff)
cmake integration of the ivigenerator
Rerun pro2cmake.py for all examples and tests. Ivigenerator based tests and examples are compiling fine, but the cmake files need to be reworked to be also able to run them. Task-number: AUTOSUITE-1633 Change-Id: Icb95ecfa62ecb319d042dc30ea9f643b69a4aacf Reviewed-by: Robert Griebl <robert.griebl@qt.io>
Diffstat (limited to 'tests/auto/core/ivigenerator/projects/org-example-echo-noprivate/frontend/CMakeLists.txt')
-rw-r--r--tests/auto/core/ivigenerator/projects/org-example-echo-noprivate/frontend/CMakeLists.txt46
1 files changed, 22 insertions, 24 deletions
diff --git a/tests/auto/core/ivigenerator/projects/org-example-echo-noprivate/frontend/CMakeLists.txt b/tests/auto/core/ivigenerator/projects/org-example-echo-noprivate/frontend/CMakeLists.txt
index d02ae04..e0bb60e 100644
--- a/tests/auto/core/ivigenerator/projects/org-example-echo-noprivate/frontend/CMakeLists.txt
+++ b/tests/auto/core/ivigenerator/projects/org-example-echo-noprivate/frontend/CMakeLists.txt
@@ -1,29 +1,27 @@
# Generated from frontend.pro.
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
-#####################################################################
-## echo_noprivate_frontend Generic Library:
-#####################################################################
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
-qt_add_cmake_library(echo_noprivate_frontend
- OUTPUT_DIRECTORY "${CMAKE_CURRENT_BINARY_DIR}/../"
- DEFINES
- QT_BUILD_ORG_EXAMPLE_ECHO_LIB
- PUBLIC_LIBRARIES
- Qt::Core
- Qt::Gui
- Qt::IviCore
- Qt::IviCorePrivate
- Qt::Qml
- Qt::Quick
-)
-
-#### Keys ignored in scope 1:.:.:frontend.pro:<TRUE>:
-# QFACE_ANNOTATIONS = "../../../no-private.yaml"
-# QFACE_SOURCES = "../../../org.example.echo.qface"
-# TEMPLATE = "lib"
+add_library(echo_noprivate_frontend)
-## Scopes:
-#####################################################################
+# IVI Generator:
+qt6_ivigenerator(echo_noprivate_frontend
+ QFACE_SOURCES ../../../org.example.echo.qface
+ QFACE_FORMAT frontend
+ QFACE_ANNOTATIONS ../../../no-private.yaml
+)
+target_include_directories(echo_noprivate_frontend PUBLIC
+ ${CMAKE_CURRENT_BINARY_DIR}
+)
-#### Keys ignored in scope 2:.:.:frontend.pro:MACOS:
-# QMAKE_SONAME_PREFIX = "@rpath"
+target_link_libraries(echo_noprivate_frontend PUBLIC
+ Qt::Core
+ Qt::Gui
+ Qt::IviCore
+ Qt::IviCorePrivate
+ Qt::Qml
+ Qt::Quick
+)