aboutsummaryrefslogtreecommitdiffstats
path: root/examples/ivicore/qface-tutorial/chapter2-enums-structs/frontend/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/ivicore/qface-tutorial/chapter2-enums-structs/frontend/CMakeLists.txt')
-rw-r--r--examples/ivicore/qface-tutorial/chapter2-enums-structs/frontend/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/examples/ivicore/qface-tutorial/chapter2-enums-structs/frontend/CMakeLists.txt b/examples/ivicore/qface-tutorial/chapter2-enums-structs/frontend/CMakeLists.txt
index 8ca17d5..e9d0815 100644
--- a/examples/ivicore/qface-tutorial/chapter2-enums-structs/frontend/CMakeLists.txt
+++ b/examples/ivicore/qface-tutorial/chapter2-enums-structs/frontend/CMakeLists.txt
@@ -21,6 +21,12 @@ find_package(Qt6 COMPONENTS IviCore)
find_package(Qt6 COMPONENTS Qml)
find_package(Qt6 COMPONENTS Quick)
+qt_add_executable(QtIviInstrumentCluster)
+
+# IVI Generator:
+qt6_ivigenerator(QtIviInstrumentCluster
+ QFACE_SOURCES ../instrument-cluster.qface
+ QFACE_FORMAT frontend
)
set_target_properties(QtIviInstrumentCluster PROPERTIES
WIN32_EXECUTABLE TRUE