aboutsummaryrefslogtreecommitdiffstats
path: root/examples/ivicore/qface-tutorial/chapter3-simulation-backend/backend_simulator/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/ivicore/qface-tutorial/chapter3-simulation-backend/backend_simulator/CMakeLists.txt')
-rw-r--r--examples/ivicore/qface-tutorial/chapter3-simulation-backend/backend_simulator/CMakeLists.txt14
1 files changed, 7 insertions, 7 deletions
diff --git a/examples/ivicore/qface-tutorial/chapter3-simulation-backend/backend_simulator/CMakeLists.txt b/examples/ivicore/qface-tutorial/chapter3-simulation-backend/backend_simulator/CMakeLists.txt
index ce270e6..8729060 100644
--- a/examples/ivicore/qface-tutorial/chapter3-simulation-backend/backend_simulator/CMakeLists.txt
+++ b/examples/ivicore/qface-tutorial/chapter3-simulation-backend/backend_simulator/CMakeLists.txt
@@ -19,29 +19,29 @@ find_package(Qt6 COMPONENTS Core)
find_package(Qt6 COMPONENTS Gui)
find_package(Qt6 COMPONENTS IviCore)
-qt_add_plugin(instrumentcluster_simulation)
+qt_add_plugin(instrumentcluster_chapter3_simulation)
# IVI Generator:
-qt6_ivigenerator(instrumentcluster_simulation
+qt6_ivigenerator(instrumentcluster_chapter3_simulation
QFACE_SOURCES ../instrument-cluster.qface
QFACE_FORMAT backend_simulator
)
-set_target_properties(instrumentcluster_simulation PROPERTIES
+set_target_properties(instrumentcluster_chapter3_simulation PROPERTIES
WIN32_EXECUTABLE TRUE
MACOSX_BUNDLE TRUE
)
-target_include_directories(instrumentcluster_simulation PUBLIC
+target_include_directories(instrumentcluster_chapter3_simulation PUBLIC
${CMAKE_CURRENT_BINARY_DIR}/../frontend
)
-target_link_libraries(instrumentcluster_simulation PUBLIC
- # Remove: L${CMAKE_CURRENT_BINARY_DIR}/../
+target_link_libraries(instrumentcluster_chapter3_simulation PUBLIC
+ QtIviInstrumentCluster_Chapter3
Qt::Core
Qt::Gui
Qt::IviCore
)
-install(TARGETS instrumentcluster_simulation
+install(TARGETS instrumentcluster_chapter3_simulation
RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"