aboutsummaryrefslogtreecommitdiffstats
path: root/examples/ivicore/qface-tutorial/chapter3-simulation-backend/backend_simulator/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/ivicore/qface-tutorial/chapter3-simulation-backend/backend_simulator/CMakeLists.txt')
-rw-r--r--examples/ivicore/qface-tutorial/chapter3-simulation-backend/backend_simulator/CMakeLists.txt42
1 files changed, 42 insertions, 0 deletions
diff --git a/examples/ivicore/qface-tutorial/chapter3-simulation-backend/backend_simulator/CMakeLists.txt b/examples/ivicore/qface-tutorial/chapter3-simulation-backend/backend_simulator/CMakeLists.txt
new file mode 100644
index 0000000..9927170
--- /dev/null
+++ b/examples/ivicore/qface-tutorial/chapter3-simulation-backend/backend_simulator/CMakeLists.txt
@@ -0,0 +1,42 @@
+# Generated from backend_simulator.pro.
+
+cmake_minimum_required(VERSION 3.14)
+project(instrumentcluster_simulation LANGUAGES CXX)
+
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+
+if(NOT DEFINED INSTALL_EXAMPLESDIR)
+ set(INSTALL_EXAMPLESDIR "examples")
+endif()
+
+set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/ivicore/qface-tutorial/chapter3-simulation-backend")
+
+find_package(Qt6 COMPONENTS Core)
+find_package(Qt6 COMPONENTS Gui)
+find_package(Qt6 COMPONENTS IviCore)
+
+)
+set_target_properties(instrumentcluster_simulation PROPERTIES
+ WIN32_EXECUTABLE TRUE
+ MACOSX_BUNDLE TRUE
+)
+target_include_directories(instrumentcluster_simulation PUBLIC
+ ${CMAKE_CURRENT_BINARY_DIR}/../frontend
+)
+
+target_link_libraries(instrumentcluster_simulation PUBLIC
+ # Remove: L${CMAKE_CURRENT_BINARY_DIR}/../
+ Qt::Core
+ Qt::Gui
+ Qt::IviCore
+)
+
+install(TARGETS instrumentcluster_simulation
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
+ LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
+)