aboutsummaryrefslogtreecommitdiffstats
path: root/examples/ivicore/qface-tutorial/chapter6-own-backend/demo_server/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/ivicore/qface-tutorial/chapter6-own-backend/demo_server/CMakeLists.txt')
-rw-r--r--examples/ivicore/qface-tutorial/chapter6-own-backend/demo_server/CMakeLists.txt46
1 files changed, 46 insertions, 0 deletions
diff --git a/examples/ivicore/qface-tutorial/chapter6-own-backend/demo_server/CMakeLists.txt b/examples/ivicore/qface-tutorial/chapter6-own-backend/demo_server/CMakeLists.txt
new file mode 100644
index 0000000..f676668
--- /dev/null
+++ b/examples/ivicore/qface-tutorial/chapter6-own-backend/demo_server/CMakeLists.txt
@@ -0,0 +1,46 @@
+# Generated from demo_server.pro.
+
+cmake_minimum_required(VERSION 3.14)
+project(chapter6-demo-server LANGUAGES CXX)
+
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+
+if(NOT DEFINED INSTALL_EXAMPLESDIR)
+ set(INSTALL_EXAMPLESDIR "examples")
+endif()
+
+set(INSTALL_EXAMPLEDIR "${INSTALL_EXAMPLESDIR}/ivicore/qface-tutorial/chapter6-own-backend")
+
+find_package(Qt6 COMPONENTS Core)
+find_package(Qt6 COMPONENTS IviCore)
+find_package(Qt6 COMPONENTS DBus)
+
+qt_add_executable(chapter6-demo-server
+ dbus_conversion.h
+ instrumentcluster.cpp instrumentcluster.h
+ main.cpp
+)
+set_target_properties(chapter6-demo-server PROPERTIES
+ WIN32_EXECUTABLE TRUE
+ MACOSX_BUNDLE FALSE
+)
+target_include_directories(chapter6-demo-server PUBLIC
+ ${CMAKE_CURRENT_BINARY_DIR}/../frontend
+)
+
+target_link_libraries(chapter6-demo-server PUBLIC
+ # Remove: L${CMAKE_CURRENT_BINARY_DIR}/../
+ Qt::Core
+ Qt::DBus
+ Qt::IviCore
+)
+
+install(TARGETS chapter6-demo-server
+ RUNTIME DESTINATION "${INSTALL_EXAMPLEDIR}"
+ BUNDLE DESTINATION "${INSTALL_EXAMPLEDIR}"
+ LIBRARY DESTINATION "${INSTALL_EXAMPLEDIR}"
+)